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1 Introduction

The IOTA Video Capture application targets the needs of the user performing an occultation at a mobile location.
The user interface is designed for smaller displays by dividing the application into multiple windows, primarily a 
main window that displays the video and has a menu bar, a controls window with large buttons that are easily 
activated either by mouse or touch screen, and a user messages window that displays relevant information.  The
user can perform manual recording or timed recording, the latter permitting unattended recording.

The rationale for the development of this application goes beyond targeting the IOTA member as an end user.  A 
key factor is that the source code belongs to IOTA, which means that as the operating environment changes the 
code can be updated by an IOTA member to reflect the new situation.  Applications used by IOTA members that 
have been developed many years ago and no longer supported may not run under the latest version of the 
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Windows operating system, sometimes forcing users to stick with older versions of the operating system.  Issues
like these are removed when IOTA owns the code.

2 Installation

Application development is based in the Visual Studio Community IDE.  As a result it targets the Windows 
operating environment, specifically Windows 8.1.  Applications developed in the Windows 8.1 environment also 
run in Windows 10.  The application may run in other windows environments such as Windows 7, but no formal 
testing has been done to verify other environments.

The application is delivered as a self installing executable.  The install executable name depends on the 
application version number, and is “iota_vc_n_n_setup.exe” where the first 'n' is the major release version 
number and the second 'n' is the minor version number.  If the executable is delivered as an e-mail attachment, 
the file name will have “.sav” appended to the end in order to pass through e-mail security systems.  Upon 
saving the executable file in a local directory, you must remove the “.sav” extension.

To start the install process, simply run the self installing executable, typically by double clicking the file name.  
The Windows OS may ask if it is OK to let the install process make changes to your computer.  Either answer 
yes if you want to continue with the install, or no to exit the install.  The IOTA Video Capture application can be 
installed in a folder of your choice or you can use the default folder.

Version 2 of the application is the first release that uses a self installing executable and it is no longer dependent 
on the download of a Visual Studio run time environment.  To avoid possible conflicts with the version 1 release, 
it is recommended that you install this release into an empty directory.

If you install this release into an existing directory into which you have previously installed the application using a
self installing executable, uninstall the previous version prior to doing the new install.  In order to uninstall the 
previous version, execute the file “unins000.exe” from the install directory which will perform the uninstall.

3 Start Up

You can typically start up the IOTA Video Capture application without paying much attention to start up variables,
that is, the application windows will simply appear on the display and you can then do the normal set up for 
recording an  occultation.  However, the first time the application is started there might be a need to pay attention
to special circumstances due to the fact that the variables that represent application configuration have not been 
saved in an options file.  In particular, one of the most important aspects of the first time start up is the 
positioning of the application windows.  Some computers have small display screens and this presents problems
with the placement of the application windows.  The window of particular importance is the main application 
window that contains the video display.  This window will always be placed within the boundaries of the display 
screen the first time the application is started.  You should then find all the start up windows, place them on your 
display where you would like them to start up in the future, and save the windows positions (see options below).

4 Video Recording

Use standard Windows mechanisms to start the application, for example by double clicking on the desktop icon 
or double clicking the ".exe" file in File Explorer.  This action will pop up an initial splash screen followed by three
windows.  The first window is the display window which as mentioned in the introduction contains a menu bar.

The second window is for user messages.  It displays information relevant to the operation and usually precedes
each piece of information with the current UTC time.  Current local time is never shown; however, the first 
message displayed is the time zone setting for the computer.  The "File" menu on the menu bar is used to save 
the user messages to a log file.

The third window to pop up is an event recording controls window containing buttons that can control the 
application.  The two control buttons used are to start and stop video recording.  If there are no video devices 
attached to your computer, this window will not appear.

There are other windows that will pop up during various user activities.  These windows are described below in 
the appropriate sections.
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4.1 Display

The Display window contains an embedded window that shows the video from the current video capture device. 
It also contains a menu bar with five menus that provide interfaces to most of the user tasks.

The File menu has two submenus, “Open” and "Exit".  Choosing “Exit” causes the application to shut down 
which closes all open child windows and the main display window.  Choosing “Open” permits the playback of an 
AVI file and opens up the playback display window (see the section on file playback).

The Events menu has two submenus.
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The "Schedule..." submenu permits scheduling an occultation event.  The "Edit and Delete..." submenu provides 
editing capabilities of existing scheduled events along with the ability to delete events.

The Display menu has five submenus.  All Display submenu selections affect only what is seen in the display 
window.  They DO NOT affect what is captured in the video recording stored on disk.

The "Brightness/Contrast" selection pops up a dialog that controls the brightness and contrast of the video 
display.  If the dialog is displayed, the "Brightness/Contrast" submenu has a check mark to the left.  To close the 
dialog you either re-select the submenu (which then closes the dialog and removes the check mark) or selects 
the 'X' in the upper right corner of the “Brightness and Contrast” window.  If there are no attached video cameras,
this submenu is deactivated.

“Pixel Saturation...” allows setting a value such that if any pixel in the video display exceeds or matches the 
value the pixel is displayed with a special color.  The special color (magenta) is one that is not seen in a star 
image and thus should stand out in the video display.

“Frame Integration...” provides software integration of consecutive frames from the video camera.  It can be 
considered supplementary to the brightness/contrast feature and it is possible to use both features at the same 
time.  If there are no attached video cameras, this submenu is deactivated.

The “Pixel Saturation...” and “Frame Integration...” dialogs can be in use at the same time, but the frame 
integration feature predominates and pixel saturation will not be in use until frame integration is canceled.

“x2 Magnification” magnifies the video display by a factor of 2 and increases the window size accordingly.

The Options menu has six submenus which when selected may cause information to be stored in an options file 
(the “Pixel Saturation...” feature described above may also store information in the options file, but it is better 
placed under the Display menu).
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"Select Video Input Device..." permits selection of a video capture device along with a frame rate and frame size.
The selected information can be saved such that the next time the application is started the video display uses 
the selected parameters.  If there are no attached video capture devices, this submenu is deactivated.

“Recording Options has several sub menus that will be described momentarily.

"Event Pending..." permits change to the way an event countdown window is displayed.

“Performance...” is a selection that is normally not used unless you are dealing with hardware that has below 
average video capture capabilities.

“Miscellaneous...” holds simple options that do not fit well into other categories.  At the moment it contains two 
options, which is to permit some spacing around record buttons for small monitor screens and to automatically 
start up the GPS window if a USB GPS receiver is attached to the computer.

"Set Windows Positions" captures the positions of the windows on the display monitor and stores the values so 
that the next time the application is started the windows will appear at the captured positions.  The position of an 
iconified window IS NOT captured.

When the “Recording Options” menu is selected a submenu appears as shown
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"File..." allows for storage of generated files to disk locations other than the default locations and permits adding 
a prefix to the default file names.  There is also a global file prefix that can be applied to all files generated by a 
scheduled event recording.

"Codec..." is used to pair a specific codec with a video file format.  If a pairing is created, that codec is used 
when a video file is created for storage to disk.  The codec used with a video format can be changed any time 
prior to the start of a recording.  If there are no attached video cameras, this submenu is deactivated.

"Duration Default..." permits setting a default recording duration.  When an event is scheduled, the dialog starts 
with the default recording duration.  That value can be modified when scheduling an event, or it can be modified 
with this submenu so that scheduling an event starts with the new default value.  If the value in the "Duration 
Default..." dialog is never set, the default value is 10 minutes.

Selecting Options submenus that are followed by "..." pops up a dialog window for additional interaction.  Some 
of the dialogs merit further discussion and are described later in this document.

The final menu on the main window menu bar is “Help”.  When that is selected a help->about submenu can be 
selected which displays the version number of the installed IOTA Video Capture in the User Messages Window.  
The message also explains how to report issues.

4.2 User Messages

This window is for displaying relevant information to the user.  It has a menu bar with one menu, namely "File".  
The "File" menu has two submenus, "Save Messages" and "Save Messages and Clear".  The "Save Messages" 
selection saves the contents of the window to a file with a ".log" extension.  It leaves the contents of the window 
intact.  In contrast, the "Save Messages and Clear" selection also creates a log file with the window contents but 
then deletes the window contents.

4.3 Control

Video recording, which means capturing the streaming video from a camera to a file stored on disk, can be 
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started manually or by a scheduled event.  When the application is activated with an attached video camera, a 
window called "Record" is displayed.

The window has two control buttons whose icons are the same shape that is seen on a typical VCR or DVR, 
namely start recording and stop recording.  If the start recording button is selected, the video stream seen in the 
display window starts being captured to a disk file.  If no options have been previously specified, then the video 
file is given an application default name and stored in a default directory.  Selecting the start recording button 
deactivates it and the stop recording button is activated.

4.4 Pop-up Windows

Pop-up windows (dialogs) appear when a submenu having text ending with “...” is selected.  The dialogs require 
that you enter specific information, and it can be closed by selecting “Cancel”, “OK”, “Save”, or “X” in upper right 
corner.  Some of the dialog windows are described below where additional information can be helpful.

4.4.1 Select Video Input Device

The “Select Video Input Device...” submenu is for choosing and formatting a specific video capture device 
attached to the computer.  When this is selected the dialog that pops up is shown below.

If only one video capture device is attached it is automatically selected in the Source list.  If multiple devices are 
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attached the application will select the default device saved in the options file or otherwise select the first one in 
the list.  The selected device streams its video to the main display window.    

There is a checkbox named “Default device” under the device selection list which if checked will make the 
highlighted device the one chosen when the application is initialized.

You can choose to have the highlighted device ignored by pressing the “Ignore Device” button.  When that is 
done the highlighted device is moved to the “Ignored devices” list.  If you later decide to remove the ignore 
property you can select the ignore device and press the “Restore device” button which then moves the device 
back to the device selection list above.  One possible use of this feature is for an installation on a laptop which 
has a built-in webcam.  If the webcam is ignored then only the devices that are plugged into a USB port will show
up on the display.  If there are no devices on the computer except for ignored devices a user message will 
appear that states there are no attached devices and the main display will be blank.

The “Set Device Properties” button when pressed will open up another dialog that allows setting properties for 
the highlighted device.  That dialog will be discussed in a moment.

The “OK” and “Cancel” buttons are used to decide if the values for the default device check box and the ignored 
devices are to be persistent, meaning that they are used the next time the application is started.  If “Cancel” is 
selected then the values are discarded.

As mentioned above, if the “Set Device Properties” button is pressed, the following dialog window pops up.

Video media properties appear to the left, including the format (PAL, NTSC, or Digital), the frame rate and frame 
size.  For an analog video device the choice is PAL or NTSC and for IOTA approved devices there is a feature 
called “Auto Detect”.  If checked, the application checks at startup time if the device driver is set to the proper 
format that reflects the camera setting.  If it is not it will switch the format to the proper one and inform the user 
as such in the User Messages window.  If automatic detection is set for a device, the application start up time will
take a couple seconds longer.  If an analog device is attached that is not in the approved device list, then the 
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“Auto Detect” check box will not appear and the two radio buttons for NTSC and PAL will be active.  NOTE: if you
have saved a device configuration for a device that has auto detect enabled and subsequently change its format 
from PAL to NTSC or vice versa, it is possible that the device will not display because the configuration does not 
match what is possible for the format.  To recover from this situation choose “Select Video Input Device...” 
followed by “Set Device Properties” and pick a valid frame rate and size.

The values in the Frame Size list box represent the width x height in pixels of the video display.  For some 
devices different formats might mean that the same picture is expanded or compressed to fit within the width x 
height values, and for other devices it might mean that more or less of the same device image is displayed in the
main display window.  The device may have frame sizes that are not shown in the list because the IOTA Video 
Capture application will not show any frame size that has a width of less than 640 or a height less than 480.

The right side of the dialog has slider bars for each property that can be set for the device.  Various devices may 
have a different number of slider bars.  When a slider bar is moved there is instant feedback in the display 
window.  For many devices the values set by the slider bars will remain persistent from one session to the next; 
however the best way to insure the same settings each time the application is initialized the “Save Device 
Configuration” box should be checked and OK pressed.  The properties in the dialog window are either from a 
device configuration or from the device driver if there is no configuration.  If the Cancel button is pressed the 
properties will not be saved even if the “Save Device Configuration” box is checked.

4.4.2 Scheduling An Event

Manually recording an occultation event requires the user to be present to start and stop the recording.  This can
be inconvenient for many reasons and points to a need for scheduling the recording period around a predicted 
event date and time.  Under the "Events" menu there is a submenu "Schedule..." that when selected pops up the
following dialog.

The above dialog starts with the "Predicted Event Date and Time (UTC)" filled in with the current date/time from 
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the computer.  The “Recording Duration” is filled in with the value set using the "Duration Default..." Option 
submenu, or the application default value of 10 minutes if the duration option was never entered.  Now the actual
event date/time can be entered.  IMPORTANT NOTE: the value entered represents the midpoint of the recording
interval.  For example, with a recording duration of 10 minutes the recording will start 5 minutes prior to the 
"Predicted Event Date and Time (UTC)" and end 5 minutes after.

Optional file prefixes can be added to the event file names.  The first prefix is the asteroid name and the second 
one is the star name.  The third prefix name (Global Prefix) is set in another dialog which has yet to be 
discussed.  All the prefixes are prepended to the files that are created when the event actually occurs.  Each 
prefix has an underscore character, '_', that is automatically added to the end of the prefix in order to highlight 
the separation between each prefix.  The final file name will look something like asteroid_star_global_etc.  The 
details of the etc portion are once again discussed in the same dialog where the global prefix is set.  When the 
event actually occurs there are two files generated.  Both will all have the same filename except for different file 
extensions.  The event video file will have “.avi” as an extension and the event log file will have “.log” as an 
extension.  When the Save button on the above dialog is pressed, an event file is created with the same 
filename as the other two files but with an “.ief” extension (ief stands for IOTA Event File).

An optional comment can be added to the scheduled event, which can be useful for a later review of the 
scheduled events or serve as a reminder of what has already been recorded by expired events.

There are two check-boxes for hibernation or shutdown of the computer after the event recording is complete.  
This might be useful for recording an event on a laptop with an internal battery as its only power source.  Only 
one of the two check-boxes can have a check mark.  If a box is checked, then upon completion of the recording 
a dialog will pop up that gives you 30 seconds to stop the hibernation or shutdown.  If not stopped within the 
allotted time then the computer is placed into hibernation or is shut down.

Sometimes hibernation is not supported on a computer, and if that is the case there is a user message upon 
application startup that indicates lack of support.  It is recommended that you test hibernation capability prior to 
using your computer in the field for a real event recording.  It is possible that there might be no message about 
lack of hibernation support even though it is indeed not supported on a specific computer so it is best to test 
hibernation capability in advance of a real event (i.e. try it with a fake event).

The shutdown choice initiates a timed computer shutdown (after the 30 seconds expires) and a video application
exit.  The timed shutdown closes all open applications and provides one last chance to prevent a shutdown.

If the Save button is selected, the event file is stored in the "Events" sub-folder in the same directory as the 
application executable.  The file is in XML format and can be examined using Notepad (avoid WordPad).  
Although it is easy enough to modify the file contents, it is recommended that you use the edit capability 
(discussed next) for modifications in order to avoid errors.

IMPORTANT NOTE:  the event date and time entry is used to calculate the recording start and stop times based 
on the duration value.  The recording start and stop times are triggered by the computer clock, thus it is 
important to keep your computer clock time reasonably accurate prior to recording an event.  Microsoft provides 
a web based automatic facility to keep your clock current, but if you do not like that facility and turn it off there 
are other web based facilities such as the NIST time server.  Alternatively you can manually set the clock if you 
have other ways of obtaining an accurate time such as from an atomic clock.

NOTE: if the maximum number of characters for either the asteroid or the star proves too restrictive, report this 
issue.  The reason for the restrictions is to keep the file pathname length to a reasonable value.

4.4.3 Edit And Delete Events

All events can be reviewed by selecting the "Edit and Delete..." submenu of the "Events" menu.  The following 
dialog pops up.
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In the above dialog the "Show expired events" checkbox is checked, and thus the dialog shows all expired 
events and one event yet to occur (there can be many yet to occur if scheduled).  The event yet to occur will shut
down the computer 30 seconds after recording completion.  Note that all the expired events are fake events 
used to test the application and to fill the above dialog with many events.

If one of the events is selected, the "Edit Selected Event" button is activated, which pops up the Schedule Event 
dialog shown earlier in this guide.  If one or more events are selected, the "Delete Selected Events" button is 
activated.  If this button is pressed, all selected events are deleted; however, just to be safe there is an "are you 
sure" dialog.

Two lines of text are shown below the events list box.  The first line shows the folder in which event files are 
stored.  This value does not change and is based upon where the application is installed.  The second line 
shows the file name of a selected event.  The event file is stored in the folder listed in the first line.

4.4.4 Event Pending

If there is an event scheduled for the future (i.e. not expired) and a video camera is attached, then an Event 
Pending window is displayed.
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As shown above the window contains a countdown field that shows how much time remains until event recording
is started.  In this case the recording duration is 14 minutes so that the start time is 7 minutes before the event 
time, and the end of recording is 7 minutes after the event time.  An alternative to showing a countdown timer is 
to show the current UTC time of the event.  In order to do that there is the "Event Pending..." submenu under the
"Options" menu, which when selected pops up a dialog that allows you to change what is displayed in the above 
Event Pending window.

If the Event Pending window is displayed because there is a scheduled event, then selecting the "Set Windows 
Positions" submenu under the "Options" menu will capture the position of the Event Pending window (along with 
all the other displayed windows) and save it in the options file so that the next time the window pops up it will 
show up in the saved position.

4.4.5 Setting The Codec

For each device attached to the computer and recognized by the application as a video capture device it is 
possible to set a default codec used when recording the video to a disk file.  The codec applies to the video 
media format output by the device.  The same media format may be used by multiple devices already attached 
to the computer or used by a device attached sometime in the future.  The format and codec need only be paired
once and the pairing then applies to any device that uses the format.  When selecting "Recording Options-
>Codec..." under the "Options" menu the following dialog pops up.

The dialog is based on the current device in use, which in this case happens to be the USB 2820 Device.  This is
the designation given to the device attached to the computer when using the StarTech SVID2USB2NS hardware 
that plugs into a USB port.  The highlighted entry in the dialog above is the codec in current use for the YUY2 
format subtype.  If there is no highlighted entry then there is no pairing in the options file.

In the dialog above it shows that the Lagarith Lossless Codec is paired with the USB 2820 device YUY2 format.  
If there is no pairing of the format with a lossless codec such as Lagarith or some other lossless codec, then a 
video recording can generate enormously large files, so consider using a format pairing.  Even using the Lagarith
codec generates large files, but they are manageable.  With the Lagarith codec a 10 minute recording might 
typically generate a 2 to 4 GB file.
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4.4.6 File Defaults

Selecting the "Recording Options->File..." submenu under the "Options" menu allows you to modify where 
recorded files and associated log files are stored, and also to modify where text files from the User Messages 
are stored.  If no defaults have been chosen, then the files are stored in subfolders of the install directory named 
“VideoFiles” and “LogFiles”.  The submenu selection also permits you to enter an optional event file global prefix.
When the submenu is selected the following dialog pops up.

The dialog has two embedded groupings, one group for setting video file defaults and the other for setting user 
messages log file defaults.  In the above example the video file grouping has been given a file prefix "vid" and 
thus the file name is indicated below as vid_mm_dd_yyyy_hh_mm_ss.avi.  If no prefix had been entered, the file 
name would instead be mm_dd_ etc., which is the application default.  Note that adding the prefix automatically 
appends the underscore character to the prefix.  The "E:\Video_Files\" entry was entered by selecting the folder 
icon just above the entry.  If you later decide to use the application default location you can clear the entry by 
selecting the folder icon that has the small circle enclosing an 'x'.  This does NOT delete any files – it merely 
changes the file storage location back to the install directory subfolder.  The same user interaction concepts also 
apply to the User Messages log file defaults.

The optional “Event File Global Prefix” will embed the text string in any files generated as a result of an event 
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scheduling or recording.  The “Host Name” button will enter the text of the computer name, which can then be 
modified if desired.  For a manual recording none of the event file prefixes are used (i.e. asteroid, star, and 
global), but instead only the prefix specified in the Video group is used.

4.4.7 Pixel Saturation

This feature permits you to determine if the video camera sensitivity is too high for the occultation recording 
situation by displaying pixels which have reached the saturation limit.  If you select the “Pixel Saturation...” 
submenu under the “Display” menu the following dialog pops up.

When the above dialog is displayed, the video display has pixel saturation enabled.  The slider bar on the dialog 
can be moved to see if any pixels are saturated according to the value set by the slider.  If the “Brightness and 
Contrast” window is activated, the values set by that window do NOT affect whether or not a pixel is saturated.  
Technically it means that the saturation filter is placed before the brightness/contrast filter in the video display 
stream.

If the pixel saturation is saved in the options file, which is accomplished by selecting the 2nd radio button and 
pressing OK, the saturation value is used every time the application starts up.  In order to eliminate this behavior 
you select the 3rd radio button and press OK.

If you select the first radio button and press OK, the pixel saturation value applies only to the current application 
session.

4.4.8 Performance

This feature can be used when the computer hardware used to execute this application drops frames when 
capturing video to a disk file.

One strategy is to select a different Microsoft video renderer besides the default, which is the Enhanced Video 
Renderer (EVR).  Two other renderers are provided, namely the VMR9 and VMR7 renderers.  The EVR is the 
future direction for Microsoft, but it can be a performance hog if hardware support is not provided.  It is possible 
that using one of the other two renderers might solve the dropped frames issue for specific computers.

Another strategy is to turn off the display while recording, which is likely the strategy with the biggest effect.  This
is a good selection to use for unattended recording since it doesn't matter if you can see the video.  One final 
strategy is to remove display filters while recording.  For example if the brightness / contrast window is in use 

14



and this checkbox is checked, then the brightness / contrast filter will not be in the video display stream when 
recording is started and the window will be hidden.  This option is a little more performance intensive than 
turning off the display because the display is still being rendered.

Selecting the “Performance...” submenu of the Options menu displays the following dialog which permits setting 
performance strategies mentioned above.

There are other things to try besides those shown on the above dialog.  If you Google “dropped video frames” 
you will find links to articles that discuss how to prevent them.  An important strategy is to prevent most interrupts
from occurring while you are recording, which might typically involve disabling your internet connection and 
stopping unnecessary background processes.

4.4.9 Frame Integration

The Frame Integration feature can normally be ignored except under circumstances where a target star is simply
too dim to be seen in the display window, even after using the brightness/contrast feature.  Frame integration will
overlay a specified number of frames on top of each other and then start over with the next set of frames.  If you 
select “Frame Integration...” under the “Display” menu, the following dialog pops up.

You can enter from 2 to 30 frames to be overlaid.  The bigger the number the more easily seen are the dim stars.
A drawback to bigger numbers is that background noise also becomes more apparent, thus the process of 
finding dim stars might take some experimentation.
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As previously mentioned, Frame Integration overrides the Pixel Saturation feature if both dialogs are displayed.  
The Frame Integration dialog will remain on the display screen until you press the “Cancel” button.

4.4.10 USB GPS Receiver

The window shown below will only pop up if there is a USB GPS Receiver plugged into a USB port.  It is shown 
by selecting the “USB GPS Receiver...” submenu under Display.  If no GPS is found it will state as such in the 
User Messages window.  The application will be unresponsive during the search for a plugged in GPS and an 
“unresponsive” dialog is shown.  If the GPS is found, the “unresponsive” dialog is closed and the GPS dialog 
appears about 5 seconds later.

This particular USB device operates at 9600 baud, but the application supports older ones that operate at 4800 
baud.  The location values update approximately every 5 seconds.  Note that the “Capture Position” and “Set 
Time Difference” buttons are disabled and are reserved for future enhancements.  The dialog can be used to 
verify your location and can be used as a cross check to the values reported by the IOTA VTI.

If the GPS window is on display when a manual recording is started, the information in the window is captured 
and the window is closed.  When the recording is ended, the information is placed in the recording log file.  The 
GPS display can be automatically restored with the “Options->Misc...” selection followed by checking the entry 
named “Automatically start USB GPS if connected”.  This applies not only to manual recording but also to event 
recording.  Thus if several events are scheduled, each event log file will have the GPS information and the GPS 
display will reappear after each event recording is completed.

5 Video Playback

When IOTA Video Capture is used to record a video stream from a capture device, the file on disk has a “.avi” 
extension (short for Audio Video Interleave).  The ability to play back an AVI file is a new feature included with 
Version 2.0 of the application.

5.1 Display

In order to enter video playback select File->Open from the recording display window menu and select a file with
a “.avi” extension.  Upon selection of a file the following window is shown.
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The playback display window has only one entry on its menu bar, which is “File”.  When an AVI file is opened the
window is automatically sized to fit the AVI file frame size.  The File menu has four submenus.

“File->Open” permits selecting an AVI file for playback.  If there is already an open file the submenu is disabled.

“File->Close” closes the current AVI file if one is open.  If there is not an open file the submenu is disabled.  
When an open file is closed the “File->Open” submenu is activated.

“File->Information” displays information about the open AVI file in the User Messages window.  The information 
includes the name of the open file, the number of recorded frames, the number of key frames, the frame size 
and frame recording rate.  The number of dropped frames is equal to the number of recorded frames minus the 
number of key frames.

The final submenu is “File->Exit”.  When selected it closes the playback window and closes the AVI file if one is 
open.  It does not exit the application.

5.2 Control

Whenever the playback main display is shown, there is also a “Playback” control window which is shown below.
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The controls are similar to those in standard recording and playback devices.  The specific controls highlighted 
above are in the situation where an AVI file has just been opened, playback was started and then paused.  The 
meaning of each control button starting from the left is:

● Play:  play the file no matter where its position (except at end of file)

● Pause:  pause the playback.

● Start of File:  position playback to the start of the file (moves slider bar all the way to the left)

● Previous Frame:  display the previous frame (slider bar will move slightly to the left)

● Next Frame:  display the next frame (slider bar will move slightly to the right)

● End of File:  position playback to the end of the file (moves slider bar all the way to the right)

The slider bar can also be grabbed with the mouse and moved in order to quickly get to a file position.  You can 
also click on the slider bar to move the position to the left or right (previous or next).  And finally, if you activate 
the slider bar by clicking on it with the left mouse button, you can use the left and right keys on the keyboard to 
move to the previous and next frames.

The playback of a file uses computer resources and is thus a potential source of interference with video file 
recording.  Dropped frames during video recording is an unacceptable situation if it can be prevented.  Thus if an
event is scheduled and a countdown window is displayed, file playback will be stopped and the windows hidden 
a few seconds before event recording begins.  If a manual recording is begun, the playback windows are 
immediately hidden and will reappear when the recording is stopped.

6 Miscellaneous

6.1 IOTA Approved Devices

The Auto Detect feature for an analog capture device is supported only for devices that have undergone 
extensive testing by IOTA.  To date there are two devices that have been approved for built-in support in IOTA 
Video Capture.  They are the StarTech SVID2USB2NS and its replacement SVID2USB23.  When they are 
connected to the computer running IOTA Video Capture they will show the names “USB 2820 Device” and “USB 
2861 Device” respectively.  Other USB analog capture devices may work well with the application but they will 
not have Auto Detect support and potentially may have other issues such as high levels of video noise.  A 
request for device support can be made by sending an e-mail to the address shown in “Help->About IOTA Video 
Application”.

6.2 Video Device Disconnect / Reconnect

Version 2 of IOTA Video Capture has added the ability to detect USB device connects and disconnects.  As an 
example, if the application is started with no attached video capture devices and then a device is plugged in, the 
application will detect the device, render its video stream in the main display window, and show the Record 
control window.

If the current video device is disconnected (accidentally or otherwise) a message is sent to User Messages.  If 
there is no other attached video capture device, the Record window will be hidden and a no attached device 
message sent to User Messages.  On the other hand if there is an alternative attached video device it will be 
displayed and the Record window will remain in place.

If a recording is occurring (manual or event) and the current device is disconnected, the disconnect message is 
sent to User Messages but there is no device switching.  Instead the display window shows a blank or frozen 
display and will remain so until the device is reconnected or the user session is exited.  Each time a device goes 
through a disconnect / reconnect cycle while recording, a new avi and log file is created with the same name as 
the original recording except that “_n” is appended to the name with the “n” being a number representing the 
cycle number.
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6.3 Memory Use

IOTA Video Capture is based on Microsoft's Common Object Model foundation which tends to be very slow 
when releasing memory that is no longer used.  For that reason the application memory use can increase 
substantially if certain user operations are performed such as changing the frame size.  Increased memory use 
will have little impact on computers with a lot of available dynamic memory, but under powered computers may 
be more likely to drop frames during recording.  To avoid such issues it is a good practice to configure your 
recording device and save the configuration in the options file prior to using it for an occultation.

7 Digital Video Cameras

The IOTA Video Capture application currently supports only analog video cameras, but the hardware trend is 
towards digital video cameras.  Some IOTA members have already installed and used digital video cameras on 
the same computers that they run the IOTA Video Capture application.  Sometimes the application may show a 
digital video camera as a possible selection when the camera is plugged into a USB port and you select the 
camera with “Devices and Formats...” submenu under the “Options” menu, but sometimes it will not show up.  It 
depends on the characteristics of the installed driver.  There is no guarantee that the application will work for a 
specific digital video camera.  Full support for digital devices is planned for subsequent releases.

8 Release History

➢ Version 1.0,  July 25, 2016

➢ Version 1.1,  November 25, 2016

• Pixel saturation feature

• Support StarTech device with audio and video input – only the video input is captured

• “Performance...” submenu under “Options” for use when computer is dropping frames

• “Display” menu and move the “Brightness/Contrast” feature as a submenu

• “Help” menu.  In this release all it does is display the application version to User Messages.

• Prevent computer from going to sleep or into hibernation during an Event countdown

• Prevent multiple instances from running on the same computer

• Add splash screen

• “Frame Integration...”  feature under the “Display” menu

➢ Version 2.0,  September 4, 2017

• Display 2x magnifier

• Global and local file prefixes

• Improve coordination between event scheduling and viewing

• Improve the codec pairing mechanism

• Device properties feature

• Add AVI file playback

• Recognize USB device connects and disconnects

• Automatic detection of the analog device format (NTSC or PAL) for IOTA approved devices

• Install setup executable eliminates need to download Microsoft runtime environment
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