
IOTA Video Applications

Version 2.2

August 22, 2018

Table of Contents

1  Introduction............................................................................................................................................2
2  Installation..............................................................................................................................................2
3  Common Foundation..............................................................................................................................2
4  Start Up..................................................................................................................................................2
5  Video Capture.........................................................................................................................................3

5.1  Display Window..........................................................................................................................3
5.1.1  Events Menu.......................................................................................................................4
5.1.2  Display Menu......................................................................................................................5
5.1.3  Options Menu.....................................................................................................................6

5.2  Dialog Windows.........................................................................................................................8
5.2.1  Select Input Device.............................................................................................................9
5.2.2  Device Properties...............................................................................................................9
5.2.3  Scheduling An Event.........................................................................................................11
5.2.4  Edit And Delete Events.....................................................................................................12
5.2.5  Event Pending..................................................................................................................13
5.2.6  Setting The Codec............................................................................................................14
5.2.7  File Defaults......................................................................................................................15
5.2.8  Pixel Saturation.................................................................................................................16
5.2.9  Frame Integration.............................................................................................................16
5.2.10  Video Magnify.................................................................................................................17
5.2.11  Crosshairs.......................................................................................................................17
5.2.12  Performance...................................................................................................................18
5.2.13  Miscellaneous.................................................................................................................19
5.2.14  USB GPS Receiver.........................................................................................................19

5.3  Control.....................................................................................................................................20
5.4  Video File Size.........................................................................................................................20
5.5  Video Device Disconnect / Reconnect......................................................................................21
5.6  Memory Use.............................................................................................................................21
5.7  IOTA Approved Devices............................................................................................................21
5.8  User Messages........................................................................................................................21

6  Video Playback.....................................................................................................................................22
6.1  Display Window........................................................................................................................22
6.2  Control.....................................................................................................................................23

7  Digital Video Cameras.........................................................................................................................25
8  Video Capture Release History............................................................................................................25
9  Video Playback Release History..........................................................................................................26

1



1 Introduction

The IOTA Video Capture application targets the needs of the user performing an occultation at a mobile location.
The user interface is designed for smaller displays by dividing the application into multiple windows, primarily a 
main window that displays the video and has a menu bar, a controls window with large buttons that are easily 
activated either by mouse or touch screen, and a user messages window that displays relevant information.  The
user can perform manual recording or timed recording, the latter permitting unattended recording.

The IOTA Video Playback application allows the user to playback an AVI video recording created by either the 
IOTA Video Capture application or by some other application.  If the AVI file was created by IOTA Video Capture 
Version 2.1 or later, additional information regarding key frames and dropped frames is available to Playback.

The rationale for the development of these applications goes beyond targeting the IOTA member as an end user.
A key factor is that the source code belongs to IOTA, which means that as the operating environment changes 
the code can be updated by an IOTA member to reflect the new situation.  Applications used by IOTA members 
that have been developed many years ago and no longer supported may not run under the latest version of the 
Windows operating system, sometimes forcing users to stick with older versions of the operating system.  Issues
like these are removed when IOTA owns the code.

2 Installation

Application development is based in the Visual Studio Community IDE.  As a result it targets the Windows 
operating environment, specifically Windows 8.1.  Applications developed for the Windows 8.1 environment also 
run in Windows 10.  The application may run in other windows environments such as Windows 7, but no formal 
testing has been done to verify other environments.

Formerly the Capture and Playback applications were delivered as separate self installing executables, but 
starting with this release the applications are combined into one.  The install executable name depends on the 
release version number, and is “iota_apps_n_n_setup.exe” where the first 'n' is the major release version 
number and the second 'n' is the minor version number – absent if a major release.  If the executable is 
delivered as an e-mail attachment, the file name will have “.sav” appended to the end in order to pass through 
most e-mail security systems.  Upon saving the executable file in a local directory, you must remove the “.sav” 
extension.  It is recommended that you remove all past installed IOTA applications before you install this release.
To do the uninstalls you should open the Control Panel and click on the “Programs and Features” link.  Look for 
all applications with a name that starts with “Iota” and uninstall each one.  You should then go to each install 
directory and either delete the entire directory or clean out unnecessary files.

To start the install process, simply run the self installing executable, typically by double clicking the file name.  
The Windows OS may ask if it is OK to let the install process make changes to your computer.  Either answer 
yes if you want to continue with the install, or no to exit the install.  The IOTA applications can be installed in a 
folder of your choice or you can use the default folder.  Both the Capture and Playback applications are installed 
into the same folder.  By default each application will have a start up icon placed on the desktop, but you can 
choose to not have that happen during the install procedure.

3 Common Foundation

Starting with this release the IOTA Video Capture and Video Playback applications are based on a common code
foundation.  This means that changes made to the common foundation will impact both applications.  The initial 
release of the common foundation adds brightness / contrast, pixel saturation, display magnification, and 
crosshairs to both applications.  These common features are discussed later in this document.

4 Start Up

You can typically start up the Capture or Playback applications without paying much attention to start up 
variables, that is, the application windows will simply appear on the display and you can then do the normal set 
up for recording an occultation or playback of a file.  However, the first time the application is started after an 
installation there might be a need to pay attention to special circumstances because the variables that represent 
application configuration have not been saved in an options file.  In particular some of the more important values 
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in the options file is the positioning of the application windows.  Some computers have small display screens and
this presents problems with the placement of the application windows which are usually placed within the 
boundaries of the display screen.  When there is no options file the three start up windows are positioned in the 
upper right corner of the display without overlapping.  You should then place the windows on your display where 
you would like them to start up in the future, and save the windows positions (see options below).  Subsequent 
start ups will place the windows in the same position as when they were saved.

5 Video Capture

Use standard Windows mechanisms to start the Capture application, for example by double clicking on the 
desktop icon or double clicking the ".exe" file in File Explorer.  This action will show an initial splash screen 
followed by three windows.

The first window is the display window which as mentioned in the introduction contains a menu bar that provides 
the interface to most of the Capture features.

The second window is for user messages.  It displays information relevant to the operation and usually precedes
each piece of information with the current UTC time.  Current local time is never shown; however, the first 
message displayed is the time zone setting for the computer.  The "File" menu on the menu bar is used to save 
the user messages to a log file.

The third window is an event recording controls window containing buttons that control the application.  The two 
control buttons are used to manually start and stop video recording.  If there are no video devices attached to 
your computer, this window will not appear.

There are other dialog windows that will pop up during various user activities.  These windows are described 
below in the appropriate sections.

Only one instance of Video Capture can execute on your computer, which is the case for this release and all 
future releases.  The reason for this is the potentially slow startup time (which can lead to a user attempt to try 
again) and because of resource sharing conflicts.

5.1 Display Window

The Display window contains an embedded window that shows the video from the current video capture device 
and a menu bar with five menus that provide interfaces to most of the user tasks.
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The File menu has one submenu named "Exit".  Choosing “Exit” causes the application to shut down which 
closes all open child windows and the main display window.  You can also exit the application by selecting the 'X'
in the upper right corner of this window.

The Help menu has one submenu named “About IOTA Video Capture”.  When selected a message is sent to the
User Messages window that contains the version number of the installed IOTA Video Capture and explains how 
to report issues.

Shown below are the submenus of the remaining three menu bar items and a brief description is given for each. 
Detailed explanations occur later in the User's Guide.

5.1.1 Events Menu

The Events menu has two submenus. 
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The "Schedule..." submenu permits scheduling an occultation event.  The "Edit and Delete..." submenu provides 
editing capabilities of existing events along with the ability to delete events.  The dialogs that pop up when these 
entries are selected are discussed later.

5.1.2 Display Menu

The Display menu has five submenus as shown below.  Display submenu selections affect only what is seen in 
the display window.  They do not affect what is captured in the video recording stored on disk except for one 
special case for “Brightness/Contrast” discussed later in Miscellaneous options.

When any of the five submenus are selected, a dialog window specific to the selection pops up on the display 
monitor.  Any of the pop up windows can be closed by selecting the 'X' in the upper right corner or by re-selecting
the Display submenu, which will have a check mark by the selection.

If there is no video capture device attached to the computer, all five Display submenus are deactivated.
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The "Brightness/Contrast" selection pops up a dialog that controls the brightness and contrast of the video 
display.

“Pixel Saturation...” allows setting a value such that if any pixel in the video display exceeds or matches the 
value the pixel is displayed with a special color.  The special color (magenta) is one that is not seen in a star 
image and thus should stand out in the video display.

“Frame Integration...” provides software integration of consecutive frames from the video camera.  It is 
supplementary to the brightness/contrast feature and it is possible to use both features at the same time.

The “Pixel Saturation...” and “Frame Integration...” dialogs can be shown at the same time, but the frame 
integration feature has priority and pixel saturation will not be in use until frame integration is canceled.

“Magnify..” permits enlarging or shrinking the Display window by up to a factor of two.

“Crosshairs...” overlays a movable set of crosshairs on the main window display.

 The dialogs that pop up when these entries are selected are discussed later.

5.1.3 Options Menu

The Options menu has eight submenus which when selected may cause information to be stored in an options 
file (the “Pixel Saturation...” feature described above may also store information in the options file, but it is more 
appropriately placed under the Display menu).
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"Select Input Device..." permits selection of a video capture device.  The selected information can be saved such
that the next time the application is started the video display uses the selected parameters.  If there are no 
attached video capture devices, this submenu is deactivated.

"Device Properties..." allows change to the properties of the current input device including frame rate and frame 
size.  The selected information can be saved such that the next time the application is started the video display 
uses the selected parameters.  If there are no attached video capture devices, this submenu is deactivated.

“Recording Options has several sub menus that will be described momentarily.

"Event Pending..." permits change to the way an event countdown window is displayed.

“Performance...” is a selection that is normally not used unless you have hardware that has below average video
capture capabilities.

“Miscellaneous...” contains five options that do not fit well into other categories.  One option  provides spacing 
around record buttons and is useful for small monitor screens.  Another option provides an automatic start up of 
a USB GPS receiver if one is attached to the computer (a GPS display window pops up if successful).  A third 
option permits insertion of the “Brightness/Contrast” feature into the video capture stream, which should not be 
used except under special categories of occultation recording.  A fourth option provides the ability to have an 
audible beep at the start and end of an event recording.  The fifth option determines where the date/time portion 
of a file name is places at the beginning or the end.

“USB GPS Receiver” is applicable only if one is plugged into a USB port, and if so it provides the location of your
computer, both in a pop up window and in a recording log file.

"Set Windows Positions" captures the positions of the application windows on the display monitor and stores the 
values so that the next time the application is started the windows will appear at the same positions.  If a window
is iconified, its position before it was iconified is captured.
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When the “Recording Options” menu is selected a submenu appears as shown below.

"File..." allows for storage of generated files to disk locations other than the default locations and permits adding 
a prefix to the default file names.  There is also a global file prefix that can be applied to all files generated by a 
scheduled event recording.

"Codec..." is used to pair a specific codec with a video file format.  If a pairing is created, that codec is used 
when a video file is created for storage to disk.  The codec used with a video format can be changed any time 
prior to the start of a recording.  If there are no attached video cameras, this submenu is deactivated.

"Duration Default..." permits setting a default recording duration.  When an event is scheduled, the scheduling 
dialog starts with the default recording duration.  The duration value can be modified when scheduling an event, 
or it can be modified with this submenu so that scheduling an event starts with the new default value.  If the 
value in the "Duration Default..." dialog is never set, the default value is 10 minutes.

Selecting Options submenus that are followed by "..." pops up a dialog window for additional interaction.  Some 
of the dialogs merit further discussion and are described next.

5.2 Dialog Windows

Pop-up windows (dialogs) appear when a submenu having text ending with “...” is selected.  The dialogs require 
that you enter specific information, and it can be closed by selecting “Cancel”, “OK”, “Save”, or “X” in upper right 
corner.  Some of the dialog windows are described below where additional information might be helpful.

When a dialog window is selected via a submenu and its position has never been saved in the options file, then 
it will appear in one of the four display corners of the display screen.  It's position is selected such that it does not
have any overlap with the main display window.  If that is not possible then its position is upper left.  If you 
subsequently move a dialog window and then close it, re selecting the window will pop it up in the same position 
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as when it was closed.  If you save windows positions to the options file, it will capture the position of any dialog 
window (even if iconified).

5.2.1 Select Input Device

The “Select Input Device...” submenu is for choosing and formatting a specific video capture device attached to 
the computer.  When this is selected the dialog that pops up is shown below.

If only one video capture device is attached it is automatically selected in the Source list.  If multiple devices are 
attached the application will select the default device saved in the options file or otherwise select the first one in 
the list.  The selected device streams its video to the main display window.    

There is a checkbox named “Default device” under the device selection list which if checked will make the 
highlighted device the one chosen when the application is initialized.

You can choose to have the highlighted device ignored by pressing the “Ignore Device” button.  When that is 
done the highlighted device is moved to the “Ignored devices” list.  If you later decide to remove the ignore 
property you can select the ignored device and press the “Restore device” button which then moves the device 
back to the device selection list above.  One possible use of this feature is for an installation on a laptop which 
has a built-in webcam.  If the webcam is ignored then only the devices that are plugged into a USB port will show
up on the display.  If there are no devices on the computer except for ignored devices a user message will 
appear that states there are no attached devices and the main display will be blank.

The “OK” and “Cancel” buttons are used to decide if the values for the default device check box and the ignored 
devices are to be persistent, meaning that they are used the next time the application is started.  If “Cancel” is 
selected then the values are discarded.

5.2.2 Device Properties

The “Device Properties...” submenu is for setting the properties of the current input device, and when selected 
the following dialog window pops up.
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Video media properties appear to the left, including the video standard PAL or NTSC, the frame rate and frame 
size.  For IOTA approved analog video devices the choice is PAL or NTSC.  The radio button that is initially 
selected is what the application detects for the current device driver setting.  This may or may not be the correct 
setting.  If the attached video camera or the video time inserter have settings that do not match the device 
properties, the video display may not appear correct and you have to either select the other video standard or 
change the attached device video camera settings via hardware switches.

If the current device is not in the approved device list, then the Frame Rate entry will instead have a list box 
below it that contains the possible frame rate values.  Once again the selected values may not match the 
attached camera or video time inserter and the display will not appear correct until you make the appropriate 
selections.

The values in the Frame Size list box represent the width x height in pixels of the video display.  For some 
devices different formats might mean that the same picture is expanded or compressed to fit within the width x 
height values, and for other devices it might mean that more or less of the same device image is displayed in the
main display window.  The device may have frame sizes that are not shown in the list because the IOTA Video 
Capture application will not show any frame size that has a width of less than 640 or a height less than 480.

The right side of the dialog has slider bars for each property that can be set for the device.  Various devices may 
have a different number of slider bars.  When a slider bar is moved there is quick visual feedback in the display 
window.  For many devices the values set by the slider bars will remain persistent from one session to the next; 
however, the “Save Device Configuration” box should be checked and OK pressed to insure you get the same 
settings each time the application is initialized.  The properties in the dialog window are either from a device 
configuration or from the device driver if there is no configuration.  If the Cancel button is pressed the properties 
will not be saved even if the “Save Device Configuration” box is checked.
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5.2.3 Scheduling An Event

Manually recording an occultation event requires the user to be present to start and stop the recording.  This can
be inconvenient for many reasons and points to a need for scheduling the recording period around a predicted 
event date and time.  Under the "Events" menu there is a submenu "Schedule..." that when selected pops up the
following dialog.

The above dialog starts with the "Predicted Event Date and Time (UTC)" filled in with the current date/time from 
the computer.  The “Recording Duration” is filled in with the value set using the "Duration Default..." Option 
submenu, or the application default value of 10 minutes if the duration option value was never saved.  Now the 
actual event date/time can be entered.  IMPORTANT NOTE: the value entered represents the midpoint of the 
recording interval.  For example, with a recording duration of 10 minutes the recording will start 5 minutes prior to
the "Predicted Event Date and Time (UTC)" and end 5 minutes after.

Optional file prefixes/postfixes can be added to the event file names.  The first prefix is the asteroid name and 
the second one is the star name.  The third prefix name (Global Prefix) is set in another dialog which has yet to 
be discussed.  All the prefixes are prepended/appended to the files that are created when the event actually 
occurs.  Each prefix/postfix has an underscore character '_' that is automatically added in order to highlight the 
separation between them and the date/time.  The final file name will look something like 
asteroid_star_global_etc. for a prefixed file name.  When the event actually occurs there are two files generated. 
Both will all have the same filename except for different file extensions.  The event video file will have “.avi” as 
an extension and the event log file will have “.txt” as an extension.  When the Schedule button on the above 
dialog is pressed, an event file is created with the same filename as the other two files but with an “.ief” 
extension (ief stands for IOTA Event File).  The decision to use a prefix or a postfix is an option determined by 
the user in the Miscellaneous dialog, discussed below.
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An optional comment can be added to the scheduled event, which can be useful for a later review of the 
scheduled events or serve as a reminder of what has already been recorded by expired events.

There are two check-boxes for hibernation or shutdown of the computer after the event recording is complete.  
This might be useful for recording an event on a laptop with an internal battery as its only power source.  Only 
one of the two check-boxes can have a check mark.  If a box is checked, then upon completion of the recording 
a dialog will pop up that gives you 30 seconds to stop the hibernation or shutdown.  If not stopped within the 
allotted time then the computer is placed into hibernation or is shut down.

Sometimes hibernation is not supported on a computer, and if that is the case there is a user message upon 
application startup that indicates lack of support.  It is recommended that you test hibernation capability prior to 
using your computer in the field for a real event recording.  It is possible that there might be no message about 
lack of hibernation support even though it is indeed not supported on a specific computer so it is best to test 
hibernation capability in advance of a real event (i.e. try it with a fake event).

The shutdown choice initiates a timed computer shutdown (after the 30 seconds expires) and a video application
exit.  The timed shutdown closes all open applications and provides one last chance to prevent a shutdown.

If the Schedule button is selected, the event file is stored in the "Events" sub-folder in the same directory as the 
application executable.  The file is in XML format and can be examined using Notepad (avoid WordPad).  
Although it is easy enough to modify the file contents, it is recommended that you use the edit capability 
(discussed next) for modifications in order to avoid errors that can cause the application to malfunction.  The 
Schedule button is active only if the predicted event time is ahead of the current computer time, thus the popped 
up dialog will initially have the button deactivated.

IMPORTANT NOTE:  the event date and time entry is used to calculate the recording start and stop times based 
on the duration value.  The recording start and stop times are triggered by the computer clock, thus it is 
important to keep your computer clock time reasonably accurate prior to recording an event.  Microsoft provides 
a web based automatic facility to keep your clock current, but if you do not like that facility and turn it off there 
are other web based facilities such as the NIST time server.  Alternatively you can manually set the clock if you 
have other ways of obtaining an accurate time such as from an atomic clock.

This dialog permits the use of the tab key to switch from one field to the next.  Also the four arrow keys work 
within the two date/time fields to move between values (left, right arrows) and to change values (up, down 
arrows).

NOTE: if the maximum number of characters for either the asteroid or the star proves too restrictive, report this 
issue.  The reason for the restrictions is to keep the file pathname length to a reasonable value.

5.2.4 Edit And Delete Events

All events can be reviewed by selecting the "Edit and Delete..." submenu of the "Events" menu.  The following 
dialog pops up.
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In the above dialog the "Show expired events" checkbox is checked, and thus the dialog shows all expired 
events and one event yet to occur (there can be many yet to occur if scheduled).  The event yet to occur will shut
down the computer 30 seconds after recording completion.  Note that all the expired events are fake events 
used to test the application and to fill the above dialog with many events.

If one of the events is selected, the "Edit Selected Event" button is activated, which pops up the Schedule Event 
dialog shown earlier in this guide.  If one or more events are selected, the "Delete Selected Events" button is 
activated.  If this button is pressed, all selected events are deleted; however, just to be safe there is an "are you 
sure" dialog.

Two lines of text are shown below the events list box.  The first line shows the folder in which event files are 
stored.  This value does not change and is based upon where the application is installed.  The second line 
shows the file name of a selected event.  The event file is stored in the folder listed in the first line.

5.2.5 Event Pending

If there is an event scheduled for the future (i.e. not expired) and a video camera is attached, then an Event 
Pending window is displayed.

As shown above the window contains a countdown field that shows how much time remains until event recording
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is started.  In this case the recording duration is 30 minutes so that the start time is 15 minutes before the event 
time, and the end of recording is 15 minutes after the event.  An alternative to showing a countdown timer is to 
show the current UTC time.  In order to do that there is the "Event Pending..." submenu under the "Options" 
menu, which when selected pops up a dialog that allows you to change what is displayed in the above Event 
Pending window.

If the Event Pending window is displayed because there is a scheduled event, then selecting the "Set Windows 
Positions" submenu under the "Options" menu will capture the position of the Event Pending window (along with 
all the other displayed windows) and save it in the options file so that the next time the window pops up it will 
show up in the saved position.

5.2.6 Setting The Codec

For each device attached to the computer and recognized by the application as a video capture device it is 
possible to set a default codec used when recording the video to a disk file.  The codec applies to the video 
media format output by the device.  The same media format may be used by multiple devices already attached 
to the computer or used by a device attached sometime in the future.  The format and codec need only be paired
once and the pairing then applies to any device that uses the format.  When selecting "Recording Options-
>Codec..." the following dialog pops up.

The dialog codec list is based on the format of the current device in use, which in the above example is the 
YUY2 Microsoft format.  Only lossless codecs are shown, and no codec is an added choice.  If there is no 
highlighted entry then there is no pairing in the options file.  Thus far Lagarith is the only lossless codec 
acceptable to the Capture program.  If you know of another lossless codec that you would like to see in the list, 
please send a message stating this to the e-mail address shown in Help->About.

If there is no pairing of the format with a lossless codec such as Lagarith, then a video recording can generate 
enormously large files, so consider using a format pairing.  Even using the Lagarith codec generates large files, 
but they are manageable.  With the Lagarith codec a 10 minute recording might typically generate a 2 to 4 GB 
file.
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5.2.7 File Defaults

Selecting the "Recording Options->File..." submenu allows you to modify where recorded files and associated 
log files are stored, and also to modify where text files from User Messages are stored.  If no defaults have been 
chosen, then the files are stored in subfolders of the install directory named “VideoFiles” and “LogFiles”.  The 
submenu selection also permits you to enter an optional event file global prefix/postfix.  When the submenu is 
selected the following dialog pops up.

The dialog has two embedded groupings, one group for setting video file defaults and the other for setting user 
messages log file defaults.  In the above example the video file grouping has been given a file postfix "vid" and 
the corresponding file name is shown just below it.  If nothing had been entered, the file name would instead not 
have the appended “_vid”.  The "E:\Video_Files\" entry was created by selecting the folder icon to the left of the 
entry.  If you otherwise decide to use the application default location you can select the “Use Default” button 
below the entry.  The same user interaction concepts also apply to the User Messages log file defaults.

If the selected directory in either of the two groups is too long to see the ending characters, you can hover the 
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mouse cursor over the entry and a text box will appear that shows the full directory path.

The optional event file global prefix/postfix will embed the text string in any files generated as a result of an event
recording.  The “Host Name” button will enter the text of the computer name, which can then be modified if 
desired.  For a manual recording none of the event file prefixes (asteroid, star, and global) are used, but instead 
only the prefixes specified in the Video and User Messages Log groups are used.

5.2.8 Pixel Saturation

This feature permits you to determine if the video camera sensitivity is too high for the occultation recording 
situation by displaying pixels which have reached the saturation limit.  If you select the “Pixel Saturation...” 
submenu under the “Display” menu the following dialog pops up.

When the above dialog is shown, the video display has pixel saturation enabled.  The slider bar on the dialog 
can be moved to see if any pixels are saturated according to the value set by the slider.  If the “Brightness and 
Contrast” window is activated, the values set by that window DO NOT affect whether or not a pixel is saturated.

If the pixel saturation is saved in the options file, which is accomplished by selecting the first radio button and 
pressing Save, the saturation value is used every time the application starts up.  In order to eliminate this 
behavior you select the second radio button and press Save.

If you close the Pixel Saturation dialog the pixel saturation feature is not applied to the video display, even if 
there is a saturation value stored in the options file.  Pixel Saturation is never applied to a recorded file.

5.2.9 Frame Integration

The Frame Integration feature can normally be ignored except under circumstances where a target star is simply
too dim to be seen in the display window, even after using the brightness/contrast feature.  Frame integration will
overlay a specified number of frames on top of each other and then start over with the next set of frames.  If you 
select “Frame Integration...” under the “Display” menu, the following dialog pops up.
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You can enter from 2 to 30 frames to be overlaid.  The bigger the number the more easily seen are the dim stars.
A drawback to bigger numbers is that background noise also becomes more apparent, thus the process of 
finding dim stars might take some experimentation.

Frame Integration overrides the Pixel Saturation feature if both dialogs are displayed. 

5.2.10 Video Magnify

The main video display window may appear too small or too large on your computer screen depending on its 
resolution.  One method to counter this issue is the use of the Video Magnify feature.  It appears under the 
Display menu, and if selected the following dialog pops up.

No matter what magnification is selected there is no change to a recorded video file.  Video files are always 
recorded as if “None” were selected.

5.2.11 Crosshairs

Crosshairs can be useful for highlighting a specific star or area in the main video display window.  The feature 
appears under the Display menu and if selected pops up the following dialog.
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The intensity can be varied to present the best visual display of the crosshairs.  For example, in a dark 
background you might want to increase the intensity.

The dialog has four arrows that move the crosshairs, and one click of any arrow moves the center of the 
crosshairs one pixel in the direction of the arrow.  The crosshairs position are shown in the Row and Column 
values, and these values represent the distance to the crosshairs center from the upper left corner of the display.

If you want to move the crosshairs center much faster than having to click the arrows many times, you can use 
the keyboard arrows which have an auto repeat capability.  The keyboard arrows will apply to the intensity value 
if the slider is highlighted, thus you need to click the left mouse button somewhere outside the slider area and 
the arrows will then affect the crosshairs position.  If you hold down a keyboard arrow more than half a second 
the auto repeat will kick in.

5.2.12 Performance

This feature can be used when the computer hardware used to execute this application drops frames when 
capturing video to a disk file.
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The video display uses computer resources, and it is possible to turn it off whenever a recording is occurring.  
Thus the top radio button can be selected, and if so the video display stops updating as soon as the recording 
starts.  This selection is the most effective for reducing the number of dropped frames.

The second radio button removes display filters when recording starts.  For example if the pixel saturation 
window is showing, the filter is not inserted into the video display during recording.  Although you can see what is
being recorded, the displayed pixels that are saturated are not highlighted.

One final possibility is to turn of the timer that updates the event pending window when the recording starts.  It is 
possible that updating this window during a recording can cause a dropped frame, this is not expected for most 
computers.

There are other things to try besides those shown on the above dialog.  If you Google “dropped video frames” 
you will find links to articles that discuss how to prevent them.  An important strategy is to prevent most interrupts
from occurring while you are recording, which might typically involve disabling your internet connection and 
stopping unnecessary background processes.

5.2.13 Miscellaneous

The Miscellaneous Options selection provides a dialog that allows you to provide certain customizations / 
preferences for your application sessions.  If you select this item under the Options menu the following dialog 
pops up.

The meaning of the checkbox entries should be self explanatory, with the exception of two of them.

The “Enable brightness/contrast in video file” selection should be used only under very specific conditions 
because it inserts the filter into the recorded file stream.  Use this feature only if you know the reason for its use.

The “Date/time at end of video file name” allows naming video files using the older method.  The newer naming 
method provides the date/time at the beginning of the file name and is in accordance with the usual naming 
method used by astronomy organizations

5.2.14 USB GPS Receiver

The window shown below will only pop up if there is a USB GPS Receiver plugged into a USB port.  It is shown 
by selecting the “USB GPS Receiver...” submenu under Display.  If no GPS is found it will state as such in the 
User Messages window.  The application will be unresponsive during the search for a plugged in GPS and an 
“unresponsive” dialog is shown.  If the GPS is found, the “unresponsive” dialog is closed and the GPS dialog 
appears about 5 seconds later.
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This particular USB device operates at 9600 baud, but the application supports older ones that operate at 4800 
baud.  The location values update approximately every 5 seconds.  The dialog can be used to verify your 
location and can be used as a cross check to the values reported by the IOTA VTI.

If the GPS window is on display when a manual recording is started, the information in the window is captured 
and the window is closed.  When the recording is ended, the information is placed in the recording log file.  The 
GPS display can be automatically restored with the “Options->Misc...” selection followed by checking the entry 
named “Automatically start USB GPS if connected”.  This applies not only to manual recording but also to event 
recording.  Thus if several events are scheduled, each event log file will have the GPS information and the GPS 
display will reappear after each event recording is completed.

5.3 Control

Video recording, which means capturing the streaming video from a camera to a file stored on disk, can be 
started manually or by a scheduled event.  When the application is activated with an attached video camera, a 
window called "Record" is displayed.

The window has two control buttons whose icons are the same as that seen on a typical VCR or DVR, namely 
start recording and stop recording.  If the start recording button is selected, the video stream seen in the display 
window starts being captured to a disk file.  If no options have been previously specified, then the video file is 
given an application default name and stored in a default directory.  Selecting the start recording button 
deactivates it and the stop recording button is activated.

Extra spacing is provided around the icons if that preference has been selected in the Miscellaneous Options 
dialog.  In order for the extra spacing to take effect, you must restart Video Capture.

5.4 Video File Size

A video file is created when either the “start record” icon is pressed or when an event recording begins because 
the recording start time has passed.  Video files can become quite large and a pre-event recording check should 
validate that there is enough disk space for the recording situation.
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The amount of disk space used per minute during a recording can significantly vary depending on the camera, 
frame size, video activity, background uniformity, and use of a codec.  As an example, a RunCam Night Eagle 
Astro run during the daytime with a fairly static background, 640x480 frame size and no codec uses about 1 
gigabyte per minute.  Under the same circumstances except that the Lagarith codec is inserted, the disk use is 
about 190 megabytes per minute.

File storage devices formatted using FAT32 have a 4 gigabyte file size limit.  If you expect to create video files 
larger than 4 gigabytes, the storage device must be either NTFS or exFAT formatted.  At the moment of this 
writing, USB flash memory drives have typically been formatted FAT32.  In contrast to flash memory, all disk 
drives that come installed in modern Windows based computers have been formatted NTFS.

5.5 Video Device Disconnect / Reconnect

IOTA Video Capture (version 2 or later) has added the ability to detect USB device connects and disconnects.  
As an example, if the application is started with no attached video capture devices and then a device is plugged 
in, the application will detect the device, render its video stream in the main display window, and show the 
Record control window.

If the current video device is disconnected (accidentally or otherwise) a message is sent to User Messages.  If 
there is no other attached video capture device, the Record window will be hidden and a no attached device 
message sent to User Messages.  On the other hand if there is an alternative attached video device it will be 
displayed and the Record window will remain in place.

If a recording is occurring (manual or event) and the current device is disconnected, the disconnect message is 
sent to User Messages but there is no device switching.  Instead the display window shows a blank or frozen 
display and will remain so until the device is reconnected, the recording is stopped, or the user session is exited. 
Each time a device goes through a disconnect / reconnect cycle while recording, a new avi and log file is created
with the same name as the original recording except that “_n” is appended to the name with the “n” being a 
number representing the cycle number.

5.6 Memory Use

IOTA Video Capture is based on Microsoft's Common Object Model foundation which tends to be very slow 
when releasing memory that is no longer used.  For that reason the application memory use can increase 
substantially if certain user operations are performed such as changing the frame size.  Increased memory use 
will have little impact on computers with a lot of available dynamic memory, but under powered computers may 
be more likely to drop frames during recording.  To avoid such issues it is a good practice to configure your 
recording device and save the configuration in the options file prior to using it for an occultation.

5.7 IOTA Approved Devices

To date there are two devices that have been approved for full support in IOTA Video Capture.  They are the 
StarTech SVID2USB2NS and its replacement SVID2USB23.  When they are connected to the computer running 
IOTA Video Capture they will show the names “USB 2820 Device” and “USB 2861 Device” respectively.  Full 
support means that the device driver provides an interface that reports its video standard as set to either PAL or 
NTSC.  When you select Device Properties for the supported devices you will see the driver video standard 
setting.  Other USB analog capture devices may work well with the application but they will not have full support 
and potentially may have other issues such as high levels of video noise.  A request for full device support can 
be made by sending an e-mail to the address shown in “Help->About IOTA Video Application”.

5.8 User Messages

This window is for displaying relevant information to the user.  It has a menu bar with one menu, namely "File".  
The "File" menu has three submenus, "Save Messages", "Save Messages and Clear", and “Clear Messages.  
The "Save Messages" selection saves the contents of the window to a file with a ".log" extension.  It leaves the 
contents of the window intact.  In contrast, the "Save Messages and Clear" selection also creates a log file with 
the window contents but then deletes the window contents.  “Clear Messages” removes all window contents but 
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does not save the contents in a log file.

The User Messages window is the same in all IOTA applications and its description is not repeated.

6 Video Playback

Use standard Windows mechanisms to start the Playback application, for example by double clicking on the 
desktop icon or double clicking the ".exe" file in File Explorer.  This action will initially show three application 
windows.

The first window is the display window which contains a menu bar that permits selection of most of the Playback 
features.

The second window is the User Messages window, and it behaves exactly the same as in the Capture 
application.

The third window is a playback controls window containing buttons that permit viewing specific frames in a video 
file or allow the user to play the video at normal speed.

Unlike the Capture application, your computer can have many instances of Playback running at the same time.

6.1 Display Window

The main display window contains an embedded window that shows the video from an opened AVI file.  Initially it
will be blank since no file is open.  The window contains a menu bar with four menus that provide interfaces to 
most of the user tasks.
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The Help menu provides the same menu item as the Capture application, that is, Help->About Iota Video 
Playback prints the version number and how to report errors in the User Messages window.  The Options menu 
has two submenus, one which allows you to select where the date/time entry appears in the log file name.  The 
other sets the positions of the application windows on the display monitor and stores the values so that the next 
time the application is started the windows will appear at the same positions.  If a window is iconified, its position 
before it was iconified is captured.

The “Display” menu contains the same submenu entries as in the Capture application with the exception of 
“Frame Integration...” which does not apply to video playback.

The Playback File menu has more entries compared to the Capture File menu because it has submenus that 
permit opening and closing video files.  Selecting the File menu brings up the submenus shown below.

“Open” and “Close” permit opening an AVI file for playback and subsequently closing it.  You do not have to close
an opened file if you wish to view another file.  If you open another file the already opened one will automatically 
be closed prior to opening the new selection.  When you select “Open” the windows file selector window will pop 
up and you then traverse the file system until you find the AVI file of interest.

When you open a file, specific information about the file is sent to the User Messages window.  You can always 
repeat the display of that information later in the application session by selecting “Information”.

6.2 Control

Video playback involves opening an AVI file and examining the contents by streaming the video and stopping the
video at frame locations of interest.  To perform these actions a playback control window is displayed at 
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application startup.  The controls are initially disabled and stay that way until an AVI file is opened.  The following
is how the control window looks when an AVI file is opened where the file either has not been generated by IOTA
Video Capture 2.1 or later versions or it does not have any dropped frames.

The control buttons have the following meaniing in order from left to right.

 Start playback

 Pause

 Go to start of file

 Go back one frame

 Go forward one frame

 Go to end of file

The control buttons are enabled or disabled according to the playback position.  For example when the file is 
initially opened the pause, go to start of file, and go back one frame are disabled as shown above.  The initial 
frame in the file is labeled as “Frame Number: 0” (real programmers start counting from zero).  The last frame is 
shown as a blank frame, thus indicating that you are at the end of the file.

The slider bar can also be grabbed with the mouse and moved in order to quickly get to a file position.  You can 
also click on the slider bar (the dark area) to move one frame to the left or right (previous or next).  And finally, if 
you activate the slider bar by clicking on it with the left mouse button, you can use the left and right keys on the 
keyboard to move to the previous and next frames.  When the slider bar is dragged with the left mouse button, 
the frame number at the slider position is shown as a tool tip below the slider.

If an opened AVI file has been created by IOTA Video Capture Version 2.1 or later and if it contains dropped 
frames then the Control window may have an additional two buttons on the right (these can be turned off via an 
option).

If you get to the end of file by any playback method (start playback, drag slide bar, etc.), a blank display screen is
shown and all controls are disabled except for the “go to start of file” button.  The reason for this is that the video 
file needs to be reset in order to be correctly traversed once again during playback due to some vagaries of the 
media display foundation.
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The two new buttons are for moving to the previous dropped frame or to the next dropped frame.  Either of these
two buttons might be disabled depending on the frame position.  The text at the bottom of the control now states 
that the current frame is either a key frame or a dropped frame.

7 Digital Video Cameras

The IOTA Video Capture application currently provides full support only for analog video cameras, but the 
hardware trend is towards digital video cameras.  Some IOTA members have already installed and used digital 
video cameras on the same computers that they run the IOTA Video Capture application.  Sometimes the 
application may show a digital video camera as a possible selection when the camera is plugged into a USB port
and you select the camera with “Devices and Formats...” submenu under the “Options” menu, but sometimes it 
will not show up.  It depends on the characteristics of the installed driver.  There is no guarantee that the 
application will work for a specific digital video camera.  Full support for digital devices is planned for subsequent
releases.

8 Video Capture Release History

➢ Version 1.0,  July 25, 2016

➢ Version 1.1,  November 25, 2016

• Pixel saturation feature

• Support StarTech device with audio and video input – only the video input is captured

• “Performance...” submenu under “Options” for use when computer is dropping frames

• “Display” menu and move the “Brightness/Contrast” feature as a submenu

• “Help” menu.  In this release all it does is display the application version to User Messages.

• Prevent computer from going to sleep or into hibernation during an Event countdown

• Prevent multiple instances from running on the same computer

• Add splash screen

• “Frame Integration...”  feature under the “Display” menu

➢ Version 2.0,  September 4, 2017

• Display 2x magnifier

• Global and local file prefixes

• Improve coordination between event scheduling and viewing

• Improve the codec pairing mechanism
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• Device properties feature

• Add AVI file playback

• Recognize USB device connects and disconnects

• Automatic detection of the analog device format (NTSC or PAL) for IOTA approved devices

• Install setup executable eliminates need to download Microsoft run time environment

➢ Version 2.1,  January 18, 2018

• Display 2x magnifier changed to provide more flexible magnification feature

• All Microsoft dialog boxes removed and replaced with modeless dialogs

• File Options dialog reworked

• Special entry in recorded AVI file provides coordination with IOTA Video Playback application

• The Brightness/Contrast can be placed into the video capture stream for special situations

• Windows screen positioning is improved for startup when there is no options file

➢ Version 2.2,  August 31, 2018

• Common foundation code for all applications

• Add crosshairs to common foundation

• Removed auto-detect feature due to its questionable reliability

9 Video Playback Release History

➢ Version 1,  January 18, 2018

➢ Version 2.2, August 31, 2018

• Common foundation code for all applications provides multiple display options
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